Problem With Atom Sticking On A Download

I have tried looking for my problem without success.

I downloaded Atom to help with my Python course, all was going well, until one day I opened it and had a message that said something along the lines of “clang is not installed on your system and PlatformIO needs it” then 3 options, 1 to install clang, 2 remind later, 3 discard code.

No matter which option I chose it moves to install PlatformIO IDE installing, then sticks on Atom dependencies and never completes.

I cant use Atom whilst it is doing this, I have tried uninstalling Atom and re installing but the same issue arises. I am new to Atom and I am lost with this issue.

Can anyone help.

screen print attached

Ian.

I too am having the same issue. Does anyone have a solution?

TBH Mark, I gave up waiting for a response.

In the end I uninstalled atom, again, deleted a file called .atom, from Windows, users file (as the install didnt remove it) then disconnected Atom from my Github account.

I then re-installed Atom and the error is now gone.

hope this helps