Problem using atom 1.32.2 as git commit editor


#1

When I use git commit from the command line git says "hint: Waiting for your editor to close the file… ", but then doesn’t finish when I close the file (or even exit atom).

This used to work, but I have relatively recently upgraded to git 2.19.1 and atom 1.32.2 and it has just stopped working. Note that it’s a while since I did the upgrades, and since I tried to do a commit, so I can’t prove that the version change is responsible. (Sorry, I can’t remember what versions I was using before the upgrade.)

git config -get core.editor shows atom --wait

I am using Ubuntu 14.04.


#2

Downgrading to Atom 1.28.0 fixed the problem with git. (Of course I couldn’t reopen projects saved by 1.32.2, but I fixed that by deleting ~/.config/Atom.)

I haven’t yet tried to identify when the regression occurred. It is also possible that actually forcing apt-get to do the reinstall is what fixed the problem, rather than the specific version it installed.


#3

1.28.2 works. 1.29.0 doesn’t work.

Given that 1.29.0 was released almost three months ago, there has to be something else about my installation which causes it to break - but without some guidance, I have no way to tell what.


#4

I’ll try and test with 1.32.2 on my Ubuntu 18.04 VM when I can. Just to confirm, did you install Atom using one of the official installation methods?

https://flight-manual.atom.io/getting-started/sections/installing-atom/#debian-and-ubuntu-debapt


#5

Yes. I followed exactly those instructions to install 1.32.2.

It is possible that my original Atom installation was done by downloading the .deb file directly, and pointing dpkg at at that. (It was quite some time ago, so I can’t remember - but I needed the curl to download the gpgkey - so probably.)

I definitely did not build Atom from source.


#6

Finally had a chance to try this out - I installed the latest release from yesterday (1.33.0) and didn’t have any issues on Ubuntu 18.04. I ran git config --global core.editor "atom --wait" and then after running git commit, Atom worked as my commit editor whether Atom was open or not.

When you said things “stopped working”, what’s the behavior you’re seeing? Atom just doesn’t show the commit editor whether Atom is started or not?


#7

“Stopped working” - gah, that’s a crap bug description! Sorry about that!

Specifically, “git commit” starts atom, and says “waiting for your editor window to close” (approximate wording), but does not complete when I close the window, or even terminate atom. (There are a couple of bash processes left which I think git is waiting on).

I will try with 1.33.0 on Monday and report back. If there continues to be a problem, I’ll include the relevant bit of the process tree. (If there is anything else that would help, left me know).