Problem searching for packages within Atom


#1

I’m on Mac.
When I click on “Install packages” within Atom, I get the following error after the “Featured Packages” tries to load (and fails) and also when I try to search for a package:

self signed certificate in certificate chain

Here’s a screenshot from the “featured packages”, the same happens when I search for a package. Other than this, (I think) I can use Atom normally.

Thanks!


#2

This means that there is a proxy between you and our servers where someone (typically your employer) has installed a “self-signed” security certificate in the proxy. A self-signed certificate is one that isn’t trusted by anyone but the person who created the certificate. Most security certificates are backed by known, trusted and certified companies. So Atom is warning you that your connection to our servers can be snooped and even hacked by whoever created the self-signed certificate. Since it is self-signed, Atom has no way of knowing who that is.

There are instructions how to disable this checking but because it has significant security implications, I wanted to make you aware first.


#3

Is it a problem? It only does that recently, why did it start becoming a problem now?


#4

Is it a problem if someone is watching the connections that everything is telling you is secure? That’s for you to decide.

Why has it only started happening recently? I don’t know. It could be that something has changed on your network or with your service provider or at your employer. All I can tell from the error message is that there is a rogue proxy between your machine and our servers.


#5

If I deactivate my anti-virus software, It works… does that mean my antivirus software is paranoid?


#6

Nevermind, It only worked temporarily…


#7

I’ve created a FAQ for this:


#8

How to disable this checking?


#9

@leedohm: Deactivating ssl check doesn’t help. Even if i run the “apm config set” command with strict-ssl false, I get the same error when searching for packages with apm:
self signed certificate in certificate chain

I’m on Windows 10 and behind a system which inspects traffic which lead to problems with certificates and certificate checks. So we are forced to deactivate the checks or include our own root certificate somewhere so that atom and apm can find it.

In another case with git (git for windows) we successfully added our own certificate in a bundle file which git uses to compare known certificates.


#10

Same issue as Mludzi, I’m on Windows 7 with a firewall that inspect https traffic and " apm config set strict-ssl false" does not solved this, I still have the self-signed certificate error


#11

Same issue as well on Windows 10 with Atom 1.26.1, despite running apm config set strict-ssl false and setting the https proxy similarly.
This seems to only impact the search of packages, as I can check for updates and even download packages from the Featured Packages list.