Problem on Atom startup

I’m using Atom for ubuntu.

Since a few days from now Atom has started behaving in a strange way:

  • ctrl+click does not work anymore (it just selects the new clicked point as if I did not press ctrl)

  • Every time I open atom, I find two unsaved files called atom (/usr/bin/atom) and ATOM_DISABLE_SHELLING_OUT_OF_ENVIRONNEMENT=false (/home/username/ATOM_DISABLE_SHELLING_OUT_OF_ENVIRONNEMENT= false)

Even if I delete these two files, every time I start atom again I find them instead of the previouly opened project.

I tried to completely reinstall Atom and even to delete /home/username/.atom folder, but nothing changed… Any suggestions?

1 Like

Same problem here but in elementary. Also I have the first problem on Windows 10.

Yes, I also have the same problems. It started yesterday for me, it was working well before.

I am not sure if this will solve your issue … but be aware that there are other folders around.

$HOME/.config/Atom for example.

If I want to totally purge Atom for a fresh install or troubleshooting I first try backing up this folder by renaming to $HOME/.config/Atom-BAK … same approach applies to $HOME/.atom … then reinstall.

A fresh installation of $HOME/.config/Atom will appear next time you run Atom.

There might be other such elusive folders for different packages. For example markdown-preview-enhanced uses $HOME/.mume

I tried deleting them too but it didn’t work. Then I realized that my Atom version (installed from Ubuntu software) was not the official one.

I installed Atom from here and these files do not appear anymore.


Still having problems with ctrl+click

Although packages in Ubuntu repo are often older than the latest version, in my Ubuntu 18.04 through Synaptic Package Manager I see Atom 1.48.0 (the latest).

[P.S.] Try Keybinding Resolver to test Ctrl+click

Is this an Atom feature?

ctrl+click actually works in any other application…

There was a regression in Atom, for now you can apply the temporary fix.

There is apparently also a separate issue with Atom installed via snap, but that’s for whoever distributes the snap version to figure out; instructions for setting up the official Atom distribution (to get it working with apt) are in the Install page of the flight manual.

2 Likes

Thank you, it helped!

What do you mean by regression? Is this a permanent choose made on purpose or a bug which will be fixed soon?

Regression is a bug introduced by a later release than the original feature. What happened was multi click was finally given an option to be disabled, but was checking the wrong config path or something.

Thanks again, I didn’t know about the definition of regression…

Problem solved :wink: