Problem Installing terminal on Ubuntu

Hi guys, I tried installing numerous terminal packages and none of them are installing. Other packages like linters, etc are all installing properly but when iI try to install a terminal package like term3, term2, terminal-tab etc I get the error message below:

apm install term3
Installing term3 to /home/arah/.atom/packages ✗

ptyw.js@0.4.1 install /tmp/apm-install-dir-120115-11939-1o4na9l.1nsh/node_modules/term3/node_modules/ptyw.js
node-gyp rebuild

npm WARN deprecated react-tools@0.11.2: react-tools is deprecated. For more information, visit https://fb.me/react-tools-deprecated
npm WARN deprecated graceful-fs@2.0.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
gyp ERR! configure error
gyp ERR! stack Error: Python executable “/snap/atom/247/usr/share/atom/resources/app/apm/bin/python-interceptor.sh” is v3.7.4, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at PythonFinder.failPythonVersion (/snap/atom/247/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/node-gyp/lib/configure.js:501:19)
gyp ERR! stack at PythonFinder. (/snap/atom/247/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/node-gyp/lib/configure.js:483:14)
gyp ERR! stack at ChildProcess.exithandler (child_process.js:282:7)
gyp ERR! stack at ChildProcess.emit (events.js:182:13)
gyp ERR! stack at maybeClose (internal/child_process.js:961:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:5)
gyp ERR! System Linux 5.3.0-28-generic
gyp ERR! command “/snap/atom/247/usr/share/atom/resources/app/apm/bin/node” “/snap/atom/247/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /tmp/apm-install-dir-120115-11939-1o4na9l.1nsh/node_modules/term3/node_modules/ptyw.js
gyp ERR! node -v v10.2.1
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘/tmp/apm-install-dir-120115-11939-1o4na9l.1nsh/package.json’
npm WARN apm-install-dir-120115-11939-1o4na9l.1nsh No description
npm WARN apm-install-dir-120115-11939-1o4na9l.1nsh No repository field.
npm WARN apm-install-dir-120115-11939-1o4na9l.1nsh No README data
npm WARN apm-install-dir-120115-11939-1o4na9l.1nsh No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! ptyw.js@0.4.1 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the ptyw.js@0.4.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/arah/.atom/.apm/_logs/2020-02-15T11_51_53_063Z-debug.log

Have you tried this actively maintained terminal package yet?

I tried it and It worked. thanks!

Nice! Thanks for let me know.