Problem in code display


#1

hi, I wrote a simple html code but the css part does not run. please guide me.

this error is displayed.
Command not configured for CSS!
Add an [issue on GitHub] or send your own Pull Request.
^C

*{
margin: 0;
padding: 0;
box-sizing: border-box;
-webkit-box-sizing: border-box;
-moz-box-sizing: border-box;
-o-box-sizing: border-box;
}

body {
background: lightblue;
font-family: tahoma;
font-size: 12px;
}

a{
color: blue;
text-decoration-line: none;
}

.wrapper{
width: auto;
margin: 20px auto;
}
.wrapper.meno{
width: 100%;
background-color: blue;
float: right;
}
.wrapper.meno ul li{
float: right;
list-style: none;
border: 1px solid #fff;
}

.wrapper.meno ul li a{
display: block;
padding: 5px 10px;
color: #fff;
}
.wrapper.meno ul li a hover{
background: yellow;
}


#2

What command are you trying to use? Mind posting a screenshot of your HTML file?


#4

this is the html & css file.

When I want to run the css file with the command+i key. This error is displayed.


#5

What do you expect to happen? CSS doesn’t get run like that. Your browser interprets the CSS when you look at a web page.


#6

mercy. So what should I do to have the code displayed correctly in Safari browser?


#7

open the html file in safari.


#8

Well, I’m doing this, but the result is not right.
I do not know which part of this menu code I’ve written wrong?


#9

You don’t have any element that has both the classes wrapper and meno, which is what .wrapper.meno is looking for. What you want is .wrapper .meno. Also, hover isn’t a tag name. That should be a:hover.