Prevent Atom from autoremoving white space between property and value in sass


#1

Hi. Since not so long ago I have a annoying behaviour while writing SASS (and only SASS). Atom automatically removes white space between property and value in sass. See gif attached. Does anybody know why?
I’ve allready disabled all community packages.

Jan-10-2018 11-40-44


#2

I don’t know for sure, but could have to do with how you’re getting an autocomplete dialog without having typed any characters of the property value. I think that you should see if it happens when you autocomplete from position: a instead of just position:.


#4

Yes, if I type the empty space AND begin typing the value it works. But that’s not how it should to really fast. If i directly choose a recommanded value, Atom deletes the empty space. As I said, in CSS and SCSS it works fine.


#5

This sounds like something that is specific to the language package. The designers probably thought to have this standard way of working.

If you cannot find answers here, you could put a note up on the package’s wet web site.

Which package are you using? (language name at right bottom & default core package or 3rd party package).


#6

I think so, yes. But there’s just Atoms own package I use: https://github.com/atom/language-sass
Well, I try to submit this issue. Thanks for the hint.


#7

It’s not the language package (language-sass). It’s the autocomplete provider (they usually start with autocomplete-).


#8

Thank you for correcting me.
I can see that by disabling autocomplete-css the auto-complete functionality ceases.

Could it be something to do with the binding between SASS and this auto-complete service?
It seems as if a normal CSS code is not influenced in this way as seen in the above GIF. (low certainty)


#9

Ha! I just disabled autocomplete-css and enabled it again. Now it works. OMG, next time I’ll try the old-school switch-on-and-off trick first.