Pressing Enter Freezes The Cursor


#1

Every time I press enter when autocomplete shows it freezes my cursor, what’s up with that? I know to accept it you press tab but if you press enter it should at least close the autocomplete box, and allow you to keep typing.

I find this very frustrating at times, am I doing something wrong?


#2

I am also suffering from this. Currently running the autocomplete+ package, along with a few others, and have installed Atom on Ubuntu 14.04 x64 so I had to build it. if there are any other details your might need from me to help diagnose this issue I would be happy to provide any information I can.


#3

@royalaid I have autocomplete +plus also, but I disabled it and left autocomplete the default package that comes with Atom, and it still has the same behavior.

When you press enter, it seems like it looses focus on the pane of that file, as if you clicked out of Atom and tried to type. So in order to be able to continue typing I have to click the editor pane again.


#4

@royalaid So the issue is with Autocomplete Plus and Autocomplete Paths. If I disable both, I can use the standard autocomplete which you have to toggle with ctrl + space, and if you press enter it works fine.


#5

@saschagehlich check this out.


#6

I don’t have Autocomplete Paths installed, but I do have autocomplete snippets installed which when disabled does not effect the symptoms.


#7

@royalaid , @saschagehlich just fixed it for Autocomplete Plus and Paths I’m not sure for Snippets. https://github.com/saschagehlich/autocomplete-paths/issues/7