Preferred line length not respected


#1

“Preferred Line Length” shows as 120 in Settings, but with soft wrap at preferred line length and wrap guide turned on, both are clearly enforcing a line length of 100. I’m using version 1.0.11. This is my config.cson

"*":
  ...
  editor:
    invisibles: {}
    preferredLineLength: 120
    softWrap: true
    softWrapAtPreferredLineLength: true

Is the preferredLineLength being overwritten somewhere?


#2

Do you have a language-specific setting for a different value?


#3

Probably not I guess since I haven’t touched languages at all, but how should I check? Thanks.


#4

@amosjyng Language packages tend to have their own preferred line length, which you can check in each package’s settings.
E.g.

But by default they should have the global value you selected.


#5

Which language are you seeing this behavior in?


#6

Ohh that’s it, I had installed the language-rust package, thanks a lot!

This was confusing though, I think it should be possible to make the language-specific overrides more obvious.


#7

I change it to 120 , but it auto change back to 80 and to ‘’

language-PHP