Preference not to open new file when opening atom


#1

I’m using atom on osx. When i click atom icon on my dock it opens new file if no file is opened. This one really annoys me. Sometimes i click icon accidentally and bang new empty file pops up that i have to close. I really hope you will make preference for that. I even went to back to textmate 1 from sublime because of that.


Option to stop creating an untitled file on launch
#2

What version are you using?

This feature was added on version 0.85 https://atom.io/releases


#3

I too get a new ‘untitled’ document when launching Atom which I then have to get rid of when I load in a project folder.

Is it in the settings? I can’t see it, currently on 0.92.0. (There’s “destroy empty panes” but I can’t see anything about not opening a blank window on start.)


#4

I’m using 0.90 and also cant find option not to open new untitled document when opening atom


#5

Also having this issue. Unable to discover option to disable the “untitled” document whenever Atom is opened.


#6

Same issue here… using version 0.127.0. Be great if it just open a new window with the sidebar expanded always.


#7

I hate to necro an old topic… but I was also looking for this in settings… and couldn’t find it straight off… is it named something I wouldn’t have noticed?

I’m on the most recent version of atom.io, updated this morning.


#8

No, there isn’t a setting for this currently.


#9

Thank you… I thought from this conversation there was one… I thought maybe I was going nuts… will need to look at writting a quick plugin that stops that…


#10

Well, since many commands will not work without an active window, the blank file is helpful.

What would be nicer is if once you open a named file the untitled file will go away.


#11

My package Save Session does this. If you don’t want the full package, you can take a look at how I did it here.


#12

Hi mpeterson2,
I’ve installed your package and, while it correctly restores the sections, it doesn’t prevent untitled tab to pop up.
I’m using Atom 0.186.

Thanks


#13

Someone please find a solution to this.


#14

Sorry I didn’t see this earlier. There is an option to stop it from opening the new file from opening called Disable New File On Open. This will stop it if it is enabled. It’s a little weird how it works, but if you want to take a look at how it’s implemented, it’s here.


#15

Thanks mpeterson2 for the answer.
Tbh, after a while, the package started to work on its own. :smile:


#16

I get a 404 error for that link.


#17

Yeah, Atom core is taking care of this now, so the file doesn’t exist anymore. This is what it used to point to.