Possible regression? auto-close bracket or paren


#1

I could be mistaken, but I believe this was working as I expected and only broke in the latest version, but I’ve been switching between atom and sublime so I am not 100%.

I have a habit of typing both open and close parens/brackets at once, in sublime when you type open parens it auto-adds the close parens, but then typing close simply moves you outside instead of actually adding a second close.

All day long in the latest atom I’ve been getting:

())

because I keep typing open then close, and I get the auto-added+ the one I typed.

Other than this little annoyance, atom has been great, the only other thing I want is light-table style clojure support, but I’m sure that will come in time.


#2

This seems like a language specific problem. So the obvious question would be: what language are you using that’s giving you ())?

I just tested this in 0.84.0 with PHP, and it types over the closing paren and gives you () as expected.


#3

I can’t replicate this behavior either. Have you tried with no packages loaded?


#4

The language I was using is Javascript.

I disabled all my add-on packages and it seems to be fixed now. When I get time I’ll try to selectively enable them to see if I can find which plugin it was.