Possible macOS Sierra Background bug?


#1

Hi everyone, I just did a clean install of MacOS Sierra an after I installed Atom, I realize something odd going on.

This is a comparison between how it looks on Sierra [left side] and El Capitan [right side]:

I think you can notice a big difference on the right side of the screen. This is happening with my old config but also if I do a clean install.

I also just test on my second screen and it looks fine, this just happen on the main screen [MacBook].


Background highlighting error
What's making these off-color fields on my ATom editor?
#2

Yes, seeing that too. Also on Sierra, and no, it didn’t happen on El Capitan.
Using two monitors - fine on Retina laptop monitor, external via HDMI recreates it. (Other text editors fine)


#3

Resolved. Had to recalibrate the external monitor.


#5

@jghull you are right, if I choose Color LCD the background looks fine. However, I use a different profile so my atom will keep looking bag. indeed this is a bug.


#6

How do other Electron-based applications look? VS Code is a similar implementation (code editor) and if it’s associated with Electron, it should be replicable there.

It’s pretty weird that it’s only visible on specific monitor profiles, and only in one version of one OS. There are a lot of possible points of failure.


#7

I just try VC Code and it has the same weird background atom has, and as soon as I change my profile everything is fine again. So I guess you’re right, this is an Electron related issue.


#8

Has anyone tried replicating this with Google Chrome? Anything rendering related could be a Chromium bug as well.


#9

This is known Chromium bug and it should be fixed with next stable version.

https://bugs.chromium.org/p/chromium/issues/detail?id=633805

To fix it now, you can:

a) change color profile to the standard one,

b) compile Atom with app.commandLine.appendSwitch('enable-gpu-rasterization', 'true');

c) run Atom with --enable-gpu-rasterization


#10

This. I went to System Preference --> Display --> Color and chose the default color profile for that monitor. Thanks.


#11

Thank dude, it solved my issue. Same thing happened, on macOS sierra with an external monitor, I just set LCD Display and it fixed the background problem.


#12

Calibrating the monitor in the System Preferences resolved the problem for me, Thanks everyone :slight_smile:


#13

This did the trick for me - thanks!


#14

yeahh right here https://support.apple.com/kb/PH25259?locale=en_US&viewlocale=en_US