--portable arg not migrating .atom on Windows

Using a fresh download of 1.41.0 x64 zip.

According to the Flight Manual (https://flight-manual.atom.io/using-atom/sections/basic-customization/#moving-to-portable-mode), using this arg when loading Atom should migrate .atom to the directory above where the .exe resides. However, I can’t get it to work at all.

If I run without the arg, it loads .atom from my home directory.
If I run with the arg, it loads .atom from my home directory.
If I create .atom in the directory above and run without the flag, it loads .atom from the directory above as a fresh install.
If I create .atom in the directory above and run with the flag, it loads .atom from the directory above as a fresh install.

At this point I’ve got no idea what to do, the arg straight up doesn’t seem to do anything.

It’s not exactly the worst issue ever since I can just copy it over, but it does seem like something that should be checked since it doesn’t seem to be doing what the flight manual says.

Executing atom --help reveals the options that goes with that command. --portable is not mentioned. Your assessment seems to be correct and I can confirm your findings.

atom --portable was possibly intended to use to port over the setup/configuration files to another folder. The environment variable ATOM-HOME was to change also. This does not go with the portable installation associated with the ZIP archive.

The portable installation is detailed at
https://flight-manual.atom.io/getting-started/sections/installing-atom/#portable-mode
Copying the .atom folder from another installation is good enough. Keep in mind the position of .atom in relation to the exe to make a true portable install.

Please consider using the improve this page link in the document page you linked us to. It is doubtful that this topic will compel someone to correct the erroneous documentation.

There we go, submitted a pull request to sort that.

Thanks for checking and clarifying!