Plugin upgrades and installs fail with: invalid version number


#1

greetings!
i have been running atom on fedora versions up to 25 for several years. i noticed a few days ago that atom listed plugins that needed to be upgraded but the upgrades were failing. i just got a more recent build of atom - this time using the copr repository - and the problem remains.

essentially, if i install or upgrade a plugin (in atom or using apm in the command line) i see something like:

gyp info it worked if it ends with ok
gyp info using node-gyp@3.2.1
gyp info using node@6.10.0 | linux | x64
gyp ERR! install error
gyp ERR! stack Error: Invalid version number: undefined
gyp ERR! stack at install (/usr/lib/node_modules/node-gyp/lib/install.js:50:21)
gyp ERR! stack at Object.self.commands.(anonymous function) [as install] (/usr/lib/node_modules/node-gyp/lib/node-gyp.js:66:37)
gyp ERR! stack at run (/usr/lib/node_modules/node-gyp/bin/node-gyp.js:72:30)
gyp ERR! stack at Object. (/usr/lib/node_modules/node-gyp/bin/node-gyp.js:133:1)
gyp ERR! stack at Module._compile (module.js:570:32)
gyp ERR! stack at Object.Module._extensions…js (module.js:579:10)
gyp ERR! stack at Module.load (module.js:487:32)
gyp ERR! stack at tryModuleLoad (module.js:446:12)
gyp ERR! stack at Function.Module._load (module.js:438:3)
gyp ERR! stack at Module.runMain (module.js:604:10)
gyp ERR! System Linux 4.10.6-200.fc25.x86_64
gyp ERR! command “/usr/bin/node” “/usr/lib/node_modules/node-gyp/bin/node-gyp.js” “install” “–runtime=electron” “–target=undefined” “–dist-url=https://atom.io/download/atom-shell” “–arch=x64” "–ensure"
gyp ERR! cwd /home/username/.atom
gyp ERR! node -v v6.10.0
gyp ERR! node-gyp -v v3.2.1
gyp ERR! not ok