Please stop auto-pairing Chinese quote marks


#1

Hi. I’m a Chinese user.

When I input a Chinese opening quotation mark (“), Atom immediately adds a Chinese closing quotation mark (”) after it.

Although I appreciate the effort of this feature, it is not helping but annoying.

The reason is simple:

When I input Chinese characters, I use a Chinese IME (Input Method Editor); and a modern IME already has a feature about quote marks which unfornately contradicts Atom’s.

An IME will give an opening mark when I hit “Shift+’” for the first time, and it remembers having done that. Later, when I hit the key combination again, the IME will give a closing mark instead. So, odd for opening and even for closing.

That feature works great as a best practice among modern IMEs.

Now, after I input an opening quotation mark in Atom, I get a closing mark as well. But IME doesn’t know that, and next I input a quotation mark, IME will give me another closing one.

The two closing marks are redundant, so I have to delete either of them.

I think every Chinese user will have the same problem of mine.

Please just remove auto-pairing for Chinese quote marks.

Thank you in advance.


[CLOSED!] [Survey] Anyone really needing Auto-pairing of “ and ”?
#2

From the bracket-matcher README:

You can toggle whether English/French style quotation marks (“”, ‘’, «» and ‹›) are autocompleted via the Autocomplete Smart Quotes setting in the settings view.

So you can disable that feature by going to the bracket-matcher settings view and disable the corresponding option:


#3

Thank you for reply, abe.

However, I don’t see anything like what you mentioned.

I’m using the lastest version of Atom. In the Settings Page, there are just around 20 fields of options.

Why you have those options while I don’t? Strange.


I’d like to make myself clear: (excuse me if this sounds rude for English is not my native language)

I have no trouble about ascii quotation marks ( " and ’ ) whose opening and closing marks are the same.

In fact, I do need this feature dealing with them. It helps a lot when coding.

What I want is just stop adding Chinese closing marks ( ” and ’ ), which I have to delete again and again.


Besides, marks like 《 and 》are with different keys. No IME will bother to change that. And auto-pairing them is OK.


#4

GrandSong, the idea with the editor providing a match for your opening bracket or quote is that you don’t have to type the closing one. So regardless of Chinese, what you do when you want to get (3+4)*5 is typing (, then 3+4, then e.g. arrow-right, *5. That is, you omit to type the closing member of the pair and replace it by a generic step to “step out of the brace”. I just tried with the Chinese IME on my OSX, and it works great and exactly as expected, except that the IME sometimes screws up with that odd/even count. But regardless you can always just “type over” that closing quote, that is, type a closing " and it will not add a closing quote, but just move over the one that is already there. This feature also works with closing brackets and so on, and in the case of a Chinese IME, also keeps the odd/even count.


#5

BTW you’re on the wrong page regarding your screenshot; what you need to do is open settings, then find packages, then in the list locate the bracket-matcher entry, and click on that package’s settings button. Sort of drilling deep.

I just discovered I do have a related peeve: the bracket-matcher extension gives you those three easy-to-grasp high-level choices to configure. But that also means a bracket is whatever the packet authors think is bracket, and that happens not to include e.g. the brackets you use in Chinese typesetting. IMHO the simple solution would be to enable users to add their own opening/closing pairs however they see fit.


#6

You have to go to the bracket-matcher settings (packages > search for bracket-matcher).

As the documentation I quoted states, the setting only operates on these special quotes, not on ascii ones.


#7

Yes, I see. It works.
I’m happy now.
Thanks.

Sorry that I didn’t dig much.

This topic can be closed.


#8

Thanks for you reply, too.
I am a Windows User and My IME is Sogou instead of the default one in the OS.
I’ve never used OSX. However, I have an iPad2 and I prefer Baidu IME (needing Jailbreak though) which I think applies better practices.

As to what you call “type over”, it is equally painful. So that’s not a solution.

Anyway, I’ve changed the settings of the package “bracket-matcher” and problem solved.


#9

The OP clearly explained that the Chinese IME inserted its own closing quotation mark. This meant he had two closing quotation marks (one inserted by the IME, one inserted by Atom), which clearly sucks.