Please keep a blank screen at the bottom of the editor。


#1

When I use the editor , I am used to keeping the cursor at the upper part of the editor .

I press enter key many times to create some blank lines at the bottom of the editor so that the cursor would be at the top of the editor .

To avoid the system crash, I should save the file frequently, but the blank lines was removed by the editor.

So I want to advice that please keep a blank screen at the bottom of the editor so that the cursor could be at the upper part of the editor .


#2

I have find a the way to solve this.

  1. Press Ctrl + , to open settings
  2. choose Editor tab.
  3. find Scroll Past End and check it.

Why didn’t the option of Scroll Past End checked by default ?



#3

Because not everybody wants it on.


#4

It’s not good for your neck if it’s not checked.


#5

You must be using a very large screen. My eyes can scan my entire screen without me moving my head at all.


#6

Perhaps we can have it on by default on macOS only. I know it’s very unexpected for that to be on by default on Windows and Linux, but seems common on macOS.