Please help in fixing symbols view


#1

I recently shifted from ST3 to Atom and to be honest i don’t want to switch back to ST3 as i like working in Atom. But I don’t know why i cannot see the list of functions in a file when i press CTRL + R

I installed atom-ctags as mentioned in some article. Now when i restart Atom i get an alert

“Warning from atom-ctags: atom-ctags replaces and enchances the symbols-view package. Therefore, symbols-view has been disabled”

And it disables the symbols view package. Now when i press CTRL + R it shows me

“No symbols found”

Also when i press CTRL + SHIFT + R it shows me error

I tried disabling / uninstalling the atom-ctags package and enable symbols-view only but still no luck.

KIndly help me fixing this as no body respond me on Stackoverflow as well. I am in a mid of project and don’t want to go again to ST3.

My OS is Ubuntu 14 LTS

Thanks


#2

Atom-ctags has always been somewhat buggy in my experience, I suggest you to contact its developer(s) directly.


#3

Is there any way i can see the list of functions and jump to it without using atom-ctags ?


#4

The built-in symbols-view package provides this functionality for the currently open file all by its own. If you want to be able to jump to the declaration of any function in a project, you have to use a ctags-compatible generator to create a tags file in the root directory of the project for it to refer to.