PlatformIO IDE installation hangs in Atom


#1

Hi all,

I’ve been using Atom for a few weeks with no issues until I tried to install platformio-ide-terminal. :slight_smile:

It is hung at this spot in the installation, I’m not getting any error:

I’m running this under Windows 10 Creators Edition.
I’ve checked the init scripts,
Cleared the saved state,
Reset to factory defaults,
No linked packages,
I’ve checked settings and configuration as well as I can and I can’t find anything relevant to what I’m seeing.

Help. :slight_smile:


#2

Just tried to install using apm install platformio-ide-terminal and got the following. Just sits there. No error, no output at all, and does not make a platformio-ide-terminal folder under ~/.atom/packages folder.


#3

One more small update…

When I try to install from the CL it does create platformio-ide-terminal folder under the .apm folder. It contains package.tgz and package.json file. It seems like it’s having an issue unpacking the package or trying to open it once downloaded. But still no errors. And I can’t find any log files.

I was able to move the package folder to the .atom/packages folder and it appears that the package is installed now. But I haven’t tested it.

Seems that it’s downloading the packages correctly but can’t move them to the proper location. Sup wit dat?


#4

And yet another update…

It appears that it downloads the packages and dependencies under .atom/.apm but is not able to unpack them and move them to the correct folder, .atom/packages. No errors, no logs.


#5

That’s an odd error, and definitely worth a bug report. You should try deleting the .apm folder and then re-downloading. As far as I know, .apm doesn’t serve any purpose aside from caching package data. If that doesn’t work, you can rename .atom to something else, reopen Atom, and the folder will be generated afresh. If the bug continues after that, then it’s probably something in APM that’s making it fail without sending a message.


#6

Thanks for the reply…

I uninstalled Atom, deleted the .atom folder, rebooted, reinstalled Atom. Checked the .apm folder and there was nothing there. Opened Atom and tried to install platform-ide-terminal. It created a bunch of folders under .apm but is stuck there.

It’s like it can’t unpack and relocate the packages.


#7

Okay. Try this: apm install platformio/platformio-atom-ide. If that doesn’t work, you can git clone the repo into a personal code folder and then run apm install and apm link to make it available to Atom via a symbolic link.


#8

I’ve done that several times,

I ran apm install platformio/platformio-atom-ide and got the following. It created a bunch more folders under .apm. Seems to have completed.


#9

Had to use two replies to get both images in…

Opened Atom and it went to this. I saw this before but fixed it by removing platformio-ide from .apm. When I got it before it just hung forever. It appears that that is happening again. Just sitting there. No errors, and I’ve searched the sys logs and can’t find anything there that seems to correlate.

Next I’ll try to clone it myself and see if that makes a difference.

One question… It seems that packages download into the .apm folder creating package.tgz and package.json file. I’m assuming these the package manager should then unpack the package file and move it all over to .atom/packages. Is this correct, because it seems that this is what’s no happening.

Oh, and now I have bild, busy-signal, and platformio-ide in the .atom/packages folder. But Atom hangs with what’s in the image every time I open it.


#10

I haven’t seen this before, and the problem has thwarted my attempts at troubleshooting it. Maybe a developer will come along and shed some insight.


#11

Hello.

Let us get some clarity… do you need the IDE part or the terminal?
The problem is there is a platformio-ide-terminal and there is a platformio-ide.
The first mentioned is the terminal without the IDE part.
See: https://atom.io/packages/search?q=platformio-ide

The last two pictures you show has to do with the IDE and not the terminal.

dP


#12

Yes, I had them try platformio-ide to see if it could be handled a different way. You raise a good point, though. @RWReynolds, are you trying to download PlatformIO, or just a terminal package? Because there are multiple terminal packages, and you can try termination and atom-terminal-tab to see if they download for you.


#13

Thanks for the reply dan,

No, I don’t need the IDE, only the terminal. The last two pictures were from trying DamnedScholar’s suggestion.

I’ve actually been to this point before. Early on, when the terminal wouldn’t load, I tried to load the IDE thinking it might somehow how be prerequisite. I understand now that that’s not the case. The platformio core is installed with Atom, according to the docs.

I left it overnight. It’s still hung this morning, the same as seen in the last image I posted.

It downloads the packages, places them in individual folders under the .atom/.apm folder but never unpacks/unzips them and moves them to the .atom/packages folder. No errors, no event log entries, no anything. Just hung. I can remove everything in the .apm folder and start all over again with the same results. I uninstalled, rebooted, downloaded a new installer, and reinstalled 3 times.

I’m taking a Udemy Python/Django course for my business. The instructor uses Atom, so I really wanted to use it as well. A little OCD of me but I like to be as consistent with those courses as possible to keep down the gottchas. lol… Right. :slight_smile:


#14

Thanks Damned,

I did try terminal-plus and a couple of other packages. Same results. I can’t seem to successfully load any packages. They all seem to get stuck in .apm folder.


#15

Yeah, I know what you mean. It is just a pain in the behind to fault find something you cannot see.

I had issues getting a terminal running on my system too.
Lucky for me I go that resolved… have a look here:
[SOLVED] " Cannot find module '..\build\Release\pty.node' "

Perhaps a silly question: How do you know the install did not complete?
Which version of Atom are you running? … version number and 32bit / 64bit.

(sigh) if all else fails you can run the Python scripts from the Windows’ native terminal.
… you do at least know that Python is working proper - right?

I hope you get this thorn of a problem removed.
Good luck + Cheers.
- Dan


#16

At this point Dan, no questions are silly. lol…

I downloaded the latest Windows 64bit installer from the Atom.io landing page.
I know that the package installation doesn’t complete because the packages don’t show up as installed in the settings package manager. And concerning the terminal package, the opportunity, + in the bottom bar, never shows up. Also the packages remain in .apm and never show up int the Atom packages folder.

Yes, Python is working fine. I installed the latest Anaconda and it all works perfectly. So, I think for the sake of expediency, that’s exactly what I’ll have to do. A separate Python terminal window. Not like that’s a big problem. This just became a challenge/vendetta. lol…

I’m going to submit it it as an issue on the Atom github and move on.


#17

It just rotten luck.

… it is best to submit an issue at the package’s repo.
The chances are more likely the issue is there.
The guys at the Atom development won’t be to much helpful, I think.

Are you logged onto your computer with admin privileges?
Did you try an install with the anti-virus shut off?

I would even go as far as suggesting a “portable” installation.
http://flight-manual.atom.io/getting-started/sections/installing-atom/#portable-mode


#18

Except that it refuses to install any packages.

Yes, I have admin privileges, and I have run the Atom installer and apm as Admin.

Thanks, I’ll take a look at the portable installation.

And thanks again for you guys assistance on this. I like Atom and could see using it, but I have to be able to load packages. And I know this is a really weird issue. I think it’s popped up some but not like this. I’m sure it’s something on my laptop.


#19

I haven’t seen this sort of behavior before. Sorry you’re going through it.


#20

I know, this is totally weird and I can’t find reference to it anywhere else.

I’m fine with using something else and continuing to work this out. There’s obviously been a lot of effort put into Atom and it’s pretty good editor. I don’t mind contributing, if only to take an opportunity to figure out some weird behavior. That’s at least some of why we do this. :slight_smile:

Thanks for your support.