Plain Text Package still highlights some words like REVIEW


#1

I’m using the plain text package (language-text) and I’d like to DISABLE the syntax coloring completely. Currently, words like REVIEW and TODO are getting rendered with color and italics.

I have looked in the source code for the language-text package, and I can’t find where these words are getting flagged for special treatment, so I’m guessing it’s actually coming from another package. Does anyone have an idea of which package would be doing that to my plain text files?


#2

That highlighting comes from the language-todo package. You can either disable the package completely or you can add the following to your styles.less:

@import "syntax-variables";

atom-text-editor::shadow {
  .text.plain {
    .storage {
      font-style: normal;
      color: @syntax-text-color;
    }
  }
}

#3

Thank you!