Php 5.6 ide setup


#1

Hi,

Is there a recommended setup for editing php 5.6 on Atom.
I tried parts of nuclide and php integrator but they seem to need php 7 and up, which is fine but wondering if someone is using some special setup for 5.6

thank you


#2

I assume your goal is to develop for php 5.6, not use php without php 7.
If you say php-integrator requires php7, I think you are right, but I definitely used it with php5.
I am not currently using it because I found it heavy and I needed to scrap my setup because of conflicts with other packages. I intend to give it another look, which will include support for legacy projects on php 5.
So, you might give it another try.

I’m curious about exploring lighter solutions, so I have looked at simple language completion, but not found something suitable. I could be interested in joining a group effort to create a better php autocompletion plugin that is not dependent on composer.


#3

I am currently running a php 5.6 website on my localhost with php-integrator using a seperate php 7.2 installation.

image

according to the php-integrator website php command needs to be:

PHP 7.1 or higher * — The code you’re actually writing can be anything ranging from PHP 5.2 up to (and including) PHP 7.1.

P.S. You can also try out ide-php which is from Atom but it is still in beta and still needs PHP7 to work.