Permission denied when saving files. Help me please¡

Hello everyone…

I have put in the task of learning to program, I am doing a course and everything is going very well until I suddenly received this announcement and then I said what happened. I inquired for hours and the answer I saw was to open Atom with administrator permissions, I did it and it stayed the same, then I reinstalled the program and it lasted a few minutes working normally and then it failed again, it also disabled the antivirus. or something that affected him and nothing was solved … I would like your help since what I do not want is to change the text editor

Thank you

How many users are on your computer?

Hello Damned

Only 1 user in the system :frowning:

Are you able to save that file with a different editor?


Is it possible for you to save the file under another file name?
Or at least copy the contents out to another file.

I have this happening on Windows7 at times.
Not yet in Atom… but for Servo Drive software from a Taiwanese company.

It is resolved when logging out the user from Windows and logging back in.
The downside is you loose unsaved work.

Sometimes it works to set the permissions on the file to the current user.
For this no log-out is required. Best to ask [web search] how it is done.

I hope you get this resolved.

It is the first editor that I use :confused:

Thank you for your recommendations, I will try to solve this problem as quickly as possible. :slight_smile:

I want to know if the permission problem is just showing up in Atom or if other editors have to deal with it, too.

With what editor do I try?
I do not know much

Someone that is very similar to atom

I’m not suggesting that you switch editors, I just want you to perform an experiment with a different program in order to see if the permission issue is specific to Atom or not. Use whatever is on your computer.

I already test with another editor and it works without problems

Okay, does it happen when you start Atom from the command line with atom --safe?

I got exactly the same problem.

  • I can open the file with atom.
  • If I try to ecit and save the file, I get the same Permission Denied Error.
  • It works to save the file with another name in the same directory.
  • atom --safe has the same behavior
  • Starting Atom with administraion rights leads to the same result
  • Editing the same file with notepad works fine.
  • There is only one User in the System, which also has full ownership rights to file

OS: Windows 10 Pro

Do the suggestions and observations in the following link apply?

Additionally, did you make the file yourself, or did someone else?

(I have no idea what’s causing the issue, I just think this info would help anyone who tries to fix it)

Antivirus disabled, still the same problem. I tried Brackets today and it had exactly the same problem. So my guess is, that it is something node.js related.

Go to your root folder
Right click it and select properties
Under general, make sure the read only button is unchecked
Then click apply.
You might have to do it anytime it declines to save.

I met the same issue and tried this : Open the file menu, and press Ctrl and Maj keys when clicking on the save option. For me, it worked, and the save was effective. (Using w7) Hope this can help

I had the same error. My antivirus/antimalware program called Bitdefender was blocking Atom, not allowing to modify the file. I went to Bitdefender settings and “whitelisted” Atom, the error went away.

What worked for me when I have this problem, and it does happen quite often, is to do the following.

step 1: copy and paste all of your html code and save it in notepad. I always save it as mycode.txt on my desktop for easy access.

step 2: repeat step 1 with your css.

step 3: remove your img folder from your project folder and place it on the desktop.

step 4: delete your index. html and style. css files and project folder. Don’t worry, you should have followed step 1 and 2 and have them backed up as text documents.

step 5: create a new project folder and create a new index and style, copy and paste code from text documents, move you img folder back into the new project folder and open it in atom.

works for me every time. I don’t know why this happens maybe a bug.
Hope this helps.

I had the same error on macOS 10.14.3, Atom Version 1.34.0.

I had the error when opening a plist file I created using defaults write ~/Desktop/filename.plist

I noticed the file permissions were owned by root:staff.

I ran chown $username:staff ~/Desktop/filename.plist and I was then able to open the file.