'Path' entries reduced in Atom's terminal


#1

I tried running a python script from atom. Got a message saying python in unrecognized. Then on checking the path entries from terminal in atom, I found python entries(and many other entries) are not there.I tried everything from re installing to manually adding entries from atom’s terminal. Nothing seems to work.Please check attached image! On left is the path entry from widows terminal. On right is the path entry from terminal in Atom pathissue|690x387


#2

The image cannot be opened. Can you consider re-uploading?


#3

I tried running a python script from atom

Since Atom does not run any code by default, it would also be helpful to know which package you are using.


#4

Are you using flatpak version?


#5


#6

I see that you’re using cmder. I do too, and it’s a huge improvement over the Windows command line. Unfortunately, there’s a chance that the PATH is being modified for cmder. You should test from the vanilla cmd.exe in order to find out which piece of software is responsible for the different PATH.