Paste and Indent current vs last line issue


#1

An issue from the beginning of this year:

I don’t know why it would assume I want to indent to the last line when I paste? Then I have to select the block and indent it or unindent it further? This is the one Atom killer in favor of sublime I’ve run into. I haven’t been able to find any fix only people seeking one. Is there a solution available?


#2

You can go to Settings -> Editor and disable the Auto Indent On Paste setting.


#3

Indeed that will remove the new line auto indentation but I like that feature.

My issue is that the only option seemly available is “Auto Indent On Paste” which indents “based on the indentation of the previous line” instead of an option to indent based on the indentation of the current line.

This causes this problem in files like HTML where if the paste is at a different indentation level from the previous line I “have to [re]select the block [after pasting] and indent it or unindent it further?”

The desired functionality is shown via gif in the issue posted at the top by someone a year ago. Its ctrl+shift+v in sublime 3.


#4

It’s really weird that there doesn’t seem to be a subscribable event for when text gets cut, copied, or pasted.