Packages stuck at "loading pages"


#1

Hi Guys ,

I am kind of first time users of atom. After installation all the packages that should appear just says “loading pages.”

I really just want to use python.

Can someone help ? has anyone else seen this problem ? i have attached a screenshot.<img

src="/uploads/github_atom/original/3X/0/f/0f3dc1e8dee849208cfed8c3eba0b1813a9f5f32.JPG" width=“538” height=“500”>

Varun


#2

Please post the absolute URL to the screenshot. The forum software knows how to handle a URL, so you don’t need an img tag.


#3

Well , here i attached screenshot again. Not sure how it got turned into text looking like a

URL


#4

What happens when you call apm ls from the command line?


#5

Well, like I said , i am kind of first time user. Can you give me quick commands call apm’s ?


#6

What operating system are you using?


#7

i am using win 7


#8

Okay, press the Windows key and r to get the Run dialog, then type cmd to get to the command line (also known as the command prompt). Type apm ls and share with us the results.


#9

Sorry to dig up the old topic, but I’m facing this issue as well. Here is the error that I’m having.

> apm ls
Built-in Atom Packages (90)
├── about@1.5.3
├── archive-view@0.61.1
├── atom-dark-syntax@0.27.0
├── atom-dark-ui@0.52.0
├── atom-grammar-test@0.6.0
├── atom-light-syntax@0.28.0
├── atom-light-ui@0.44.0
├── autocomplete-atom-api@0.10.0
├── autocomplete-css@0.11.2
├── autocomplete-html@0.7.2
├── autocomplete-plus@2.31.1
├── autocomplete-snippets@1.11.0
├── autoflow@0.27.0
├── autosave@0.23.1
├── background-tips@0.26.1
├── base16-tomorrow-dark-theme@1.1.0
├── base16-tomorrow-light-theme@1.1.1
├── bookmarks@0.41.0
├── bracket-matcher@0.82.1
├── command-palette@0.38.0
├── deprecation-cop@0.54.1
├── dev-live-reload@0.47.0
├── encoding-selector@0.22.0
├── exception-reporting@0.39.0
├── find-and-replace@0.201.0
├── fuzzy-finder@1.3.0
├── git-diff@1.1.0
├── go-to-line@0.31.0
├── grammar-selector@0.48.1
├── image-view@0.58.2
├── incompatible-packages@0.26.1
├── keybinding-resolver@0.35.0
├── language-c@0.52.1
├── language-clojure@0.21.0
├── language-coffee-script@0.47.2
├── language-csharp@0.12.1
├── language-css@0.37.1
├── language-gfm@0.88.0
├── language-git@0.15.0
├── language-go@0.42.1
├── language-html@0.45.1
├── language-hyperlink@0.16.0
├── language-java@0.23.0
├── language-javascript@0.119.0
├── language-json@0.18.2
├── language-less@0.29.5
├── language-make@0.22.2
├── language-mustache@0.13.0
├── language-objective-c@0.15.1
├── language-perl@0.35.0
├── language-php@0.37.2
├── language-property-list@0.8.0
├── language-python@0.45.0
├── language-ruby@0.69.0
├── language-ruby-on-rails@0.25.0
├── language-sass@0.56.0
├── language-shellscript@0.22.4
├── language-source@0.9.0
├── language-sql@0.23.0
├── language-text@0.7.1
├── language-todo@0.28.0
├── language-toml@0.18.0
├── language-xml@0.34.9
├── language-yaml@0.26.0
├── line-ending-selector@0.5.0
├── link@0.31.1
├── markdown-preview@0.158.0
├── metrics@0.53.1
├── notifications@0.65.0
├── one-dark-syntax@1.3.0
├── one-dark-ui@1.5.0
├── one-light-syntax@1.3.0
├── one-light-ui@1.5.0
├── open-on-github@1.2.0
├── package-generator@1.0.0
├── settings-view@0.242.2
├── snippets@1.0.2
├── solarized-dark-syntax@1.0.2
├── solarized-light-syntax@1.0.2
├── spell-check@0.67.1
├── status-bar@1.4.1
├── styleguide@0.47.0
├── symbols-view@0.113.0
├── tabs@0.100.2
├── timecop@0.33.2
├── tree-view@0.208.2
├── update-package-dependencies@0.10.0
├── welcome@0.34.0
├── whitespace@0.33.0
└── wrap-guide@0.38.1

Community Packages (33) C:\Users\******\.atom\packages
├── atom-dark-fusion-syntax@1.2.4
├── atom-gooey-syntax@0.2.1
├── atom-liquid-snippets@0.3.0
├── atom-ternjs@0.15.0
├── autocomplete-cmake@0.3.1
├── autocomplete-glsl@0.2.3
├── build-cmake@0.6.3
├── chester-atom-syntax@0.1.1
├── clutterskull-syntax@2.1.0
├── dark-flat-ui@1.2.4
├── darkmatter-theme@1.4.2
├── envy-theme@0.1.1
├── formatter@2.12.3
├── jekyll@1.4.2
├── language-batch@0.3.3
├── language-bridlensis@2.1.1
├── language-cmake@0.2.0
├── language-gradle@0.0.3
├── language-groovy@0.6.0
├── language-liquid@0.5.1
├── language-nlf@1.1.5
├── language-nsl@2.1.1
├── language-rust@0.4.6
├── language-shadercode@2.0.0
├── minimap@4.25.0
├── nsis-plugins@1.2.1
├── one-dark-dim-syntax@0.1.0
├── one-dark-vivid-syntax@1.1.2
├── one-sharp-syntax@1.1.1
├── permanent-delete@0.1.5
├── piatto-light@2.0.2
├── platformio-ide-terminal@2.2.0
└── xcode-theme@1.4.0

└── (empty)

I’m on Windows 10. The settings pane stuck at loading packages just as the guy here. I took a look at the developer panel, and here is the error it is throwing for you.

Hope this helps. In case you need any more data, I’m ready to provide.


#10

Does this happen when you open Atom from the command line with atom --safe?


#11

No it doesn’t, when I run with the --safe option, everything worked pretty fine. I think I should now try removing the extensions and start adding one by one to see which is the culprit. Is there any other easy way?


#12

Wait, it seemed to solve itself, after launching with --safe and then relaunching in normal mode, all my extensions are back, and this is working fine as expected. Even the packages are now being shown in the GUI.


#13

There is not. If you ever need to do that, you should skim the list for any obvious culprits, and if there aren’t any you can start with the packages that are the biggest and potentially most intrusive (like Emmet, Nuclide, or PlatformIO), or just the most recent. Then there are some that should never cause problems (language packages and autocomplete providers, for instance).


#14

03/07/2017 - It’s still happening to me.