Packages Installation requesting xcode git


#1

On updating package, it’s requesting to install Xcode tools (for git) even though I have installed git from scm and made sure PATH environment pointing to git-scm and not xcode git.

It seems that atom/install script ignores an environment (PATH) variables i’ve set to point to git. Is it because the atom process is running in launchd?

Running OS X Yosemite.

This issue is bypassed by installing from the terminal.

npm http GET https://registry.npmjs.org/emissary
npm http GET https://registry.npmjs.org/extend
npm http GET https://registry.npmjs.org/lodash/2.4.1
npm http GET https://registry.npmjs.org/js-beautify
npm http GET https://registry.npmjs.org/temp
npm http GET https://registry.npmjs.org/strip-json-comments
npm http GET https://registry.npmjs.org/js-yaml
npm http GET https://registry.npmjs.org/analytics-node
npm http GET https://registry.npmjs.org/node-uuid
npm http GET https://registry.npmjs.org/atom-message-panel
npm http GET https://registry.npmjs.org/editorconfig
npm http GET https://registry.npmjs.org/loophole
npm http GET https://registry.npmjs.org/typescript-formatter
npm http GET https://registry.npmjs.org/prettydiff

npm WARN git config --get remote.origin.url returned wrong result (https://github.com/Glavin001/Coffee-Formatter.git) xcode-select: note: no developer tools were found at ‘/Applications/Xcode.app’, requesting install. Choose an option in the dialog to download the command line developer tools.


#2

Yes, if the PATH environment variable is set in your login script for Terminal, then it isn’t set when you start Atom from the icon.


#3

ok thanks.

There isn’t anyway around this at all? i’ve seen solutions try launchctl setenv PATH “/usr/local/bin:$PATH” but that hasn’t seem to help in this instance.


#4

This is more of an OS X issue than an Atom issue … but here’s what I found:


#5

yeah, fair enough.

These solutions seemed to work for previous OS X, but not for Mavericks/Yosemite.

will just stick to the command line for the moment.