Packages Doesn't Seem to Work

When I try to install ‘script’ or any other package. Atom fails to find it. When I tried to search for in on the website the search engine seemed to be broken.

5 Likes

I seem to have exactly the same problem, tried installing atom-sass in atom and from a website. Neither worked.

1 Like

I don’t think anyone is out there.

I am having this same issue. When I try to type anything in the search, it says “Searching for “…” has failed.”

I am experiencing the same issue as well.

Hopping on this bandwagon as well same issue resulting error whenever i try to search

i.filter is not a function
[object Object]

I have exactly the same problem.I tried to download packages from chrom,mozila and safari but it seems it doesn’t work.

any explanation?

There is an explanation that I found by running atom.io in http://dns.squish.net/
The resolved DNS points show a heroku error (presumably where packages are hosted). This error has appeared over a number of years and I am concerned that atom is useless for package management. There should be some central point which records these major issues … not this discussion forum.

Same here, does anybody know why this is happening? I’m taking an online Python course and I really need to install a terminal (a package e.g. Scripts). Thanks,

I found an alternative repo … by searching around …

but I have no idea how this compares with the usual repo.
You will need to manually install.

Looks like the Packages Server Gods heard my plea. Packages is back! :slight_smile:

It seems to have come back. Searching results in a 500 error although the front page still works. Any idea why this is happening?

1 Like

Ye… I tried to download the love ide, but shows the same error. i. Filter is not a function

The gremlin is back again …

as a workaround (but without search facility) use this link followed by the name of the package …

https://atom-io.githubapp.com/packages/

e.g. https://atom-io.githubapp.com/packages/markdown-preview-enhanced

or https://atom-io.githubapp.com/packages/love-ide