Package uninstall


#1

When I uninstall a package and try to find it again it’s not possible to install it again without any extra actions.


#2

What are those actions?


#3

You need to manually remove it from config.cson
And I’m still not sure if it’s really enough.


#4

It looks like it’s not enough
0.205 is my build version


#5

Installed and uninstalled packages don’t show up in the config.cson, perhaps you’re thinking of disabled packages?


#6

I’m not sure, what you mean


#7

What exactly are you doing? What are you expecting to happen? What is actually happening?


#8

I’ve installed a package
Then uninstalled (looks like nothing really happend, but button changed back to ‘Install’)
Searched for the package again
In the packages list it has buttons “Disable”, “Settings”, “Uninstall” again

Same problem for different packages


#9

If you restart Atom, can you search for and install the package normally?


#10

No, right now I can’t uninstall any package after any numbers of restarts


#11

Is the issue that you cannot install packages? Or uninstall them?


#12

I can’t uninstall and reinstall packages


#13

Maybe you can quit Atom and then use the apm command from the command line. Then you can show us the output. Then we know exactly what is going on.


#14

I’ve updated to 0.207 and now it works o__O


#15

This happened to me yesterday.

I had a package (atom-ternjs) that was disabled, and after clicking uninstall it just stayed here, greyed out. Clicking enable did not change it’s status either. Pulling up the atom dev console showed a message saying the package could not be found. My packages folder did not contain this package, running the atom command Incompatible packages: Clear cache did not work and neither did uninstalling and reinstalling atom.

In case someone comes across this thread, the solution was to reinstall the package via apm (in windows you have to call apm from the powershell, git bash will not work).