Package Requires Binary


#1

If I create a package and it requires a binary to be used, is it OK to include it in the package so it’s included with apm install?

Specifically, the package requires a Go binary that parses Go files and gives you information based on that file.

If not, I believe they have to go get the file then go install which are extra steps.

Edit:
Since this should be able to work on all platforms, I guess including a binary isn’t the right choice.


#2

There are quite a few packages that require extra steps from the user, especially the ones that parse code or otherwise interact with external programs.