Package name collisions?


#1

A couple weeks ago I thought I had published my first package eval-selection.

I was pretty certain is had been published. Ran apm publish and all that. Pretty sure I remember seeing it listed.

I check on it today, and there’s someone else’s package there with the same name. Looks like they may have published before me, but apm should throw “name collision” errors or something.


#2

I don’t know if there might be a race condition, but I just tried publishing a package with the name “eval-selection” and here’s the output I got when I tried to publish a version number that exists in the package that is already in the registry:

$ apm publish minor
Preparing and tagging a new version ✓
Pushing v0.1.0 tag ✓
Publishing eval-selection@v0.1.0 ✗
Creating new version failed: Version exists

And then I tried to publish a version that does not exist in the existing package:

$ apm publish major
Preparing and tagging a new version ✓
Pushing v1.0.0 tag ✓
Publishing eval-selection@v1.0.0 ✗
Creating new version failed: Git tag not found

Each time it clearly showed that the publish failed. An error code was returned each time as well. It definitely could be a better error message though.


#3

Yeah, I’m willing to bet that my memory of actually publishing it is a false one. Better error message would be nice though :smile:


#4

Filed atom/apm#176 for this. Feel free to add repro steps if you like. I’m not going to be able to until I get home from work.