Package Listing in Atom Failed


#1

hi,

In Atom when i want to install new packages, It fails at searching the packages (I’m on Windows 10).It always says:

Searching for “haskell” failed. Show output…

when i click on Show output the box gets bigger but nothing is shown.

<div class="padded" style=""><pre class="error-details text"></pre></div>

The only time i get an error message is when i open the Packages Tab:

Fetching local packages failed. Error: Fetching local packages failed.
  at c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\settings-view\lib\package-manager.js:89:21
  at module.exports.PackageManager.runCommand.exit (c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\settings-view\lib\package-manager.js:59:16)
  at module.exports.BufferedProcess.handleEvents.triggerExitCallback (c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\src\buffered-process.js:213:47)
  at ChildProcess.<anonymous> (c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\src\buffered-process.js:235:18)
  at emitTwo (events.js:87:13)
  at ChildProcess.emit (events.js:169:7)
  at Process._handle.onexit (child_process.js:1057:12)
c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\settings-view\l…:288 (anonymous function)c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:804 _rejectedc:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:830 (anonymous function)c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:1064 Promise.whenc:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:748 promise.promiseDispatchc:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:564 (anonymous function)c:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app.asar\node_modules\q\q.js:110 flushnode.js:357 _tickCallback

I already made a complete reinstall of node and atom, but it still happens


#2

well thats unfortunate. seems like noone has any idea at all


#3

Perhaps you’re having the same issue as here:

Atom uses the COMSPEC Environment Variable to find the location of the command line interpreter, which is cmd.exe by default. Can you verify COMSPEC has a correct value and if not, restore it to C:\WINDOWS\system32\cmd.exe and see if that solves your issue?


#4

I have already found that issue and tried everything which is said there.

atom.packages.getApmPath();
"C:\Users\Administrator\AppData\Local\atom\app-1.0.5\resources\app\apm\bin\apm.cmd"
C:\Users\Administrator>SET COMSPEC
ComSpec=C:\WINDOWS\system32\cmd.exe

to me this looks correct


#5

If you’re sure that it’s not the issue @Alchiadus linked to, I’d recommend opening a new one on the repository, which should give the core devs and more people a chance to look at this.


#6

Indeed that looks correct.

I see two open issues that appear to be similar to yours with unfortunately no solution at the time of writing this:


The latter has the needs-reproduction label, perhaps you can mention you are running into the same problem and ask what kind of information they need to hopefully find the problem (and solution)?


#7

Here’s what caused the issue for me:

On my Windows desktop I have two user accounts, one for work, and the other for personal use.

  1. On my work account, I have 4 Atom windows open.
  2. Switch users to my personal account.
  3. Open Atom. WIthout my knowledge, Atom auto-updates. I close Atom
  4. Switch back to work account
  5. Old instances of Atom still running
  6. Close all windows and restart Atom, updated version is now running and back to normal.

I looked at the Help… and version number of Atom running and noticed it was different than the path being returned when running atom.packages.getApmPath();

So then I noticed that it had been updated without me being notified, so a simple restart of Atom solved it.

Not sure how it could be addressed - maybe a notification if Atom detects its been updated and is still running the older version - or retaining the atom\app-x.x.x\resources\app folder in the old directory so it would still work. But then again, the cleanup is also a good thing…


#8

Have the same problem here. I’m sure I didn’t mess with Command Prompt


#9

Having the same issue.


#10

Hi all,
I’m having the same issue. One thing that I think might have something to do with it is me installing NVM (Node Version Manager). For those that don’t know, it lets you install different versions of NodeJS…the only thing you have to be weary of, is when installing NPM packages globally, they will ONLY* install to that specific version of Node.

"C:\Users\Administrator\AppData\Roaming\nvm"

The Node Versions I have:

  • Node v4.2.1
  • Node v6.0.0
  • Node v6.3.0

Let’s say we open up Node v6.3.0

"C:\Users\Oneeezy\AppData\Roaming\nvm\v6.3.0\node_modules"

The Globally Installed Node Modules:

  • bower
  • gulp
  • npm

I can only assume this is where My* problem begins… shouldn’t I be seeing APM in there somewhere? I’m not completely sure. Does anyone know if this is my issue??


#11

Atom uses its own copy of Node for everything it does. So unless you went changing things inside Atom’s directories, you can install as many copies of Node and install Node modules globally as you like :grinning: I have three versions of Node installed as well!


#12

In case it’s of any help to any future reader:

Uninstalling my local Node.js version magically removed all the problems mentioned above. I agree with @leedohm that this sounds illogical and it could just be a side effect of something else, but if you are stuck like me and have tested all other options, consider re-/unistalling Node to see what happens.