Package List Not Showing Installed Packages?


#1

i’ve searched and haven’t found any other posts that explain a fix, have found multiple reports on it though. Sincere apologies if there happens to be a thread that does have a full “how to fix”. This is on a Mac btw.

My package list is not showing all my packages that are installed. But they all are loaded and working fine from the command pallette. When I run “atom --safe” in the terminal they all show up fine.

How can I debug this assuming it is a bad installed package? that is the only thread I’ve seen with a solution and the packages they have reported causing conflicts aren’t installed.

Things I’ve tried:

  • disabled packages with long load times reported by Time Cop
  • disabled just about every package I installed myself
  • uninstalled all themes I’ve installed
  • ran Atom Specs, no errors
  • ran Package Specs, no errors

I’m kind of green to Atom and the full environment, but I get most of it, so this is throwing me for a loop.

Any suggestions would be appreciated.
Thank you.


#2

I’ve never heard of this before. Is there an open bug on it on https://github.com/atom/apm or https://github.com/atom/settings-view?

How are you trying to show the list of installed packages? Can you give us some hint of repro steps?


#3

just using the standard preferences view, I can see them all in the Command Palette no problem though, they all show in Time Cop as well.

i wish i knew more about Atom debugging to give more info, but that is the behavior.

thank you for replying.

edit: the latest Atom update seemed to have fixed it! wooohooo