Package.json engines question


#1

I want to update split-diff to use block decorations for spacing and remove the hack to inject soft wrap lines.

Is it enough to change the engines tag in the package.json to be “>=1.6.0” or am I misunderstanding what that is used for? Would users installing my package on v1.5.0 receive the version of my package without block decorations automatically?


#2

Atom should not update to or install a version of your package that isn’t compatible with their version of Atom. So yes, that should be sufficient. (We do recommend changing it to something like >= 1.6.0 < 2.0.0 though.)