Package is stuck on enable even though it's not installed


#1

So i’m developing a package that I have had installed through apm link and it works fine. But now after switching branch the package is stuck with the Enable button. I have done an apm unlink, apm uninstall, made sure that the package does not exist under .atom/packages or .atom/dev/packages and it does not show up under the packages tab, but if I search for the package under the install tab (the package is released) it still just gives me the Enable button.

I have tried removing the Atom folder under ~/Library/Application Support and the .atom/compile-cache folder, and reinstalled Atom.app but nothing works.

Is there any other cache atom is using that could cause this?

I have of course tried switching back to the branch I recently worked on and had enabled, but still just have the Enable button that doesn’t work.


#2

Is it in your list of disabled packages in your config.cson?


#3

It is not listed as a disabled package


#4

Other thoughts:

  • Have you restarted Atom?
  • Have you tried just apm install package-name from the command line?
  • Have you tried removing or renaming the ~/.atom/storage directory?

#5

apm install made it work :slight_smile: The command must do something special I guess :slight_smile: Thanks