Package for Eiffel language

Hi all, I installed Atom (1.40.1) on my PC because supposedly have support for Eiffel language. I try to install the package for this language but get the error:

npm ERR! code E400
npm ERR! 400 Bad Request: https://www.atom.io/api/packages/language-eiffel/versions/0.2.1/tarball

it seems that the repository was deleted at github. Maybe it was moved to another repository?

Thanks.

Maybe try this:

apm install https://github.com/isbkch/eiffel-syntax

OK, this install the package. But when open Atom I get an error about “Deprecated calls and deprecated selectors”

Sorry, eiffel-syntax is actually just a syntax theme – not a highlighter for the Eiffel language. Unfortunately, the tars for packages are not stored by GitHub the way Node packages are stored.

However, since there is a TextMate version of the syntax highlighter, you can easily convert it:

apm init --package ~/.atom/packages/language-eiffel --convert https://github.com/textmate/eiffel.tmbundle

Consider publishing the package yourself, so others can benefit from it!

Thanks, that works :grinning: There are some things I don’t like, but I will read the documentation to see how add some minor modifications. Thanks.