Package failed to install in windows 7 x64


#1

Sir/Mam,(any 1 out there)
Iam new to this software and also new to programming.But anyway iam fallin in love with this software .
Now to the issue" when i try to install the packages ERROR pops up
Installing “minimap@3.4.9” failed.
then i check for it
it says
Unable to download https://www.atom.io/api/packages/minimap/versions/3.4.9/tarball: getaddrinfo ENOTFOUND

then i search for solution they all say use command line .But i dont know how to use command line in windows 7x64 and i am not connecting via proxy so what is the issue PLZ HELP?
I am greatly thank full to you guys if u could WRITE IT STEP BY STEP FOR BEGINNERS TO SOLVE THE ISSUE…
Thanks


#2

From my limited experience, ENOTFOUND is a common problem with not just one cause. I believe it means that the package cannot be found or downloaded. You say you are using a proxy, so that throws up a red flag to me. It is probably your proxy set up, if other people, not using a proxy, can currently download the package. But, that is only a guess.

What solutions have you found (that are using the command line)? Maybe we can help you get those working.


#3

BELOW are ss for your reference plz help i dont know where am i going wrong,thank you
[URL=http://www.imagesup.net/pt-1414203582961.png][/URL]
[URL=http://www.imagesup.net/pt-314203582964.png][/URL]
[URL=http://www.imagesup.net/pt-1614203582965.png][/URL]
[URL=http://www.imagesup.net/pt-1214203582979.png][/URL]
[URL=http://www.imagesup.net/pt-1214203582970.png][/URL]
[URL=http://www.imagesup.net/pt-1414203584490.png][/URL]


#4

The error message says that you have not installed git. Or perhaps you have installed git, but it’s not in your path.

The starting point for downloading git is here: http://git-scm.com/downloads
The Windows installer asks you a couple of questions, one of them is the option to make sure that git is “in the path”. Perhaps it’s described as “you can invoke git from the command line”. You need to make sure that this is selected.

Perhaps you have already installed git, but it’s not in your path. Suppose installing git has produced a number of files, amongst them the file C:\some\folder\git.exe. Then you will want to add C:\some\folder to the path. Into the search field under the start button, enter “environment variables”, that should lead you to the right spot in the control panel. One of the environment variables is “Path”, and when you edit it you see that it is a list of folders separated by semi-colon (";"). Just add C:\some\folder to that list, again using semi-colon as a separator.

Did that help?


#5

Sir,
I followed your instruction and added it to environment.
[URL=http://www.imagesup.net/pm-9142036353716.png][/URL]

But when i add package i get this error

Thank you for any suggestions…


#6

Just to make sure, did you restart Atom? Environment Variables are passed to an application when it’s started, so a change in Environment Variables needs an application restart before it’s reflected in that application.


#7

Sir ,still iam getting the same error.Unable to install the package


#8

Have you taken a look at the Atom Issues list? You might want to try this search to find issues similar to yours and see what their solutions were:


#9

Sir,i have gone through the issue .Can please suggest me the procedure to install the package manually
i think manually it might work…
thank you


#10

Once again, search is your friend:

I would recommend against using manual installation as a general rule though. (And I can’t personally vouch for the instructions because I haven’t tried them.)


#11

Perhaps I’m too slow, but by now your post contains placeholder images instead of the real thing. The placeholders are rectangles with text in them: “No Image by that name was found!”. So I can’t do much right now.


#12

thank you guys for help
i hope there will be some work around .
or else my last option will be is to use it in linux


#13

I went ahead and just posted the image for you, @mindfreak. You should be able to just drag images into the edit box and post them. Having to click through to some external image host that has lame ads and perhaps malware is bothersome at times.


#14

The system is not able to find the address of www.atom.io. Hm. On the command line, what happens when you type ping www.atom.io and then hit the Return key (also known as the Enter key)?

You can start a command line by entering cmd into the search field in the start menu.

If ping www.atom.io tells you that it sent three packets to a specific IP address then it’s something in Atom. (Even though it doesn’t receive any responses from that IP address.)

But if ping www.atom.io tells you that it doesn’t know which IP address to ping, then it’s a problem outside Atom.


#15

Sir,sorry for late reply (outstation),this what i get


#16

Thanks for the nice response. Unfortunately, I can’t imagine what could cause Atom to fail resolving addresses, whereas ping resolves them just fine. Anyone?

Last straw: I notice that the cmd is running as administrator. If Atom is not running as administrator, then it could be a firewall or something. Very weird. Very weird.


#17

Thank you for your help guys may be i w8 for some update …thanks for you support :smile: