Overriding editor based styles in syntax theme stopped working


#1

In the theme I currently working on, overriding syntax themes stopped working. For one, I styled the gutter to be transparent. I also tested it in other themes by trying something simple like this:

atom-text-editor,
atom-text-editor ::shadow,
:host {
  .gutter {
    background-color: #f00;
  }
}

adding an !important also doesn’t help.

Disabling the Shadow DOM option in preferences helps. But isn’t there a way around this? Am I addressing it incorrectly?


#2

Ok so I solved it, apparently the Atom-Beautify package adds the extra space before ::shadow and caught me off guard. Why does it do this though?