Override Windows menu hotkeys?


#1

I’ve successfully built a Windows version and am trying to set the keys to match my OS X keys. Most of this will consist of changing “ctrl-” to “alt-” since the Alt key on a Windows keyboard is physically in the same position as a Mac Cmd key.

My first test was to set the palette to “shift-alt-p” but “alt-p” (with or without shift) is causing the Packages menu to be activated. When I press Esc to dismiss the Packages menu it does actually then run the command.

Is there a way to eliminate the hotkeys on the menus?

In fact, I think it might be reasonable to eliminate all hotkeys for the menu since everything should be available via hotkeys and the command palette. If necessary, an option to eliminate them would be nice.


#2

Nothing? This seems really important… Lots of editors use Alt- shortcuts and these really need to be able to override menus.


#3

I don’t have a Windows machine to test on, but if you can reproduce the Shift+Alt+P behavior when running on a current version of Atom and running atom --safe then I would suggest filing a bug. You should include with it a GIF of the Keybinding Resolver and menu behavior when you reproduce the issue.


#4

I had a similar complaint under linux. I’m not sure the same solution will work for Windows, but I was able to remove the alt shortcuts from the menu by adding some code to my init script.

Here’s the post: Alt-<key> menu-bar interaction overrides shortuts