[OS X 10.10.3] Unable to open folders from terminal with atom


I see that you should be able to open folders from the terminal with this:

atom .

Or open mutiple with:

atom ./someFolder ./someOtherFolder

None of that seems to work for me. When I try any of the above, it opens just a blank window and I stll have to navigate to what I want to edit. Is this normal behavior?


Can’t replicate this on Windows. Seems to be fine.
Can you confirm you’re using v1.0?

Can you also try adding --safe and open the dev tools to see if there are any errors being spit out?


Pardon my ignorance as I am fairly new to atom. How would one open the dev tools?

I did check in the about section for Atom and I can confirm that it is 1.0.0

Do you want me to add —safe to the end of my atom . command?


Yes, sorry I should have clarified:

Starting atom with the --safe switch will start it in safe mode, which disables all community packages. This allows you to rule out one of them being the cause of the problem, if it then still rears its ugly head.
However, I don’t actually know whether the --safe switch works if you already have a bunch of folders in your command line call. Worth trying, though.

The dev tools can be opened with Ctrl+Alt+i (on Win and Linux) and I assume (!) it’ll be Cmd+Opt+i on Mac accordingly.
If the dev tools console shows you anything red, that may be a good hint at something having gone wrong.


You can tell if Atom is in Safe Mode by the green square symbol on the left side of the status bar:

Can you show a screenshot of what you’re seeing?

Atom Freeze

@batjko: Ok, that works and there is no errors at all in the console but the functions still do not work.


@leedohm: So it looks like the —safe switch is not working. I do not have a icon like in your screenshot.


Try quitting Atom first, and then run atom --safe - if you run Atom from the command line when you have a blank window open already, it’ll just add the folder to the existing blank window instead of opening a new window in safe mode.


@mnquintana: I just tried that on twodifferant machines, both running 10.10.3 and get the same result.


That’s definitely worth opening an issue on Github then.
You can try getting rid of the .atom/storage folder and seeing if the --safe switch then works.

But opening an issue on the repo woud be helpful for someone to fix it.


@batjko: I think you right. I will do that. Thank you to everyone for the help.