Opening file from context menu on Windows 10 does not gain focus


#1

On my Mac if I right click on a file in Finder then open it with Atom, the file is opened and Atom comes to the front. On my Windows 7 computer, Atom also gets focus when I right click on a file and open it. But on Windows 10, when I right click on a file, then open with Atom, Atom does not get focus. Rather the Windows 10 icon flashes, then I have to click it, in order to view the file in Atom.

Is anyone else experiencing this issue on Windows 10?


#2

I’ve seen this too, there’s an issue open for it here if you want to subscribe:

The initial report is about Ubuntu but later comments confirm the behavior on Windows as well.


#3

Thanks, at least I know it’s not me!


#4

Okay, I just tried again, and it’s working! If I right click on a file, then select “Open in Atom” from the context menu, Atom gets focus and the is brought to the foreground! I’ve tried this numerous times over the past week and it did not work under Windows 10. I’m using version 1.14.4 x64.

Yippeee!


#5

Hmmm, I still see it on Windows 10 but only the second time I open a file from the context menu. So with Atom closed, I can reproduce with:

  1. From File Explorer, right-click some text file and click “Open with Atom”
  2. After Atom opens, go back to Explorer and right click some other file and click “Open with Atom” again.

At this point, Atom doesn’t gain focus and the icon in the taskbar flashes.


#6

I cannot get this to fail now if I try! I tried exactly what you suggested, I tried with Atom minimized, and not minimized, and now whenever I right click on a file and select “Open in Atom” from the context menu, Atom comes to the front and gets focus! This is with version 1.14.4 x64. I’m almost positive I had the focus issue with this version. But now it works. Maybe Atom is not the problem, and a Windows update resolved it?


#7

Oh interesting - not sure why it’s working for you but not myself and others (I just checked and I’m all updated on Windows 10) but thanks for sharing the behavior you’re seeing in that issue :bow:


#8

Focus mysteriously started working on my HP Envy laptop running Windows 10 Pro. I also have an HP Pavillion running Win 10 Pro. Focus was not working, even though I was running version 1.15.0 x64. But then focus began working after I changed the following configuration settings:

System ->
Show in file context menus
Show in folder context menus

After enabling these two options, focus began working! I’m not sure why, but I now have two computers where Atom gains focus and comes to the front when right clicking a file in Explorer and selecting “Open file in Atom”.


#9

I’ve only just started using atom. I have exactly the same experience as the original poster. 64-bit Windows 10. Sometimes atom get focus but generally not. And not just a right-click context menu. Just the default open (double click on file, or select & press Enter) will open the file in atom but Explorer retains focus. But not always. Notepad++ works correctly i.e. gets focus when a file is opened from Explorer. It’s definitely an atom ‘thing’ not an OS thing.


#10

off topic
LibreOffice does the same thing. Very irritating.