Opening file from command prompt does not work


#1

Hey everyone,

I have two bugs to report.

  • windows 7
  • atom v1.14.0-beta4 (windows 64bit installer)
  • cygwin v2.6.1
  1. I can’t open files directly from cygwin and cmd with:
    /path/to/atom.exe /path/to/file

This worked with Atom v.1.12 beta
Atom just opens with the last opened files, but does not open the file.

  1. I used v.1.12 beta from the .zip file before installing v1.14, so I tried to test 1) with the .zip version.
    But I can’t use it, since I can’t unzip it, since the name of one specific file is too long (see screenshot).
    The path for unpacking is not really long:
    C:\Users<9chars>\Documents\programme

Best
Philipp


#2

Remark:
Also atom --version does not work as intended. It also opens atom.

In contrary to the older version:

uiae@uiae:~$ atom12 --version
Atom : 1.12.0-beta5
Electron: 1.3.6
Chrome : 52.0.2743.82
Node : 6.3.0


#4

Remark2:

Using the .zip version from the latest stable release none of these problems occur.
So I could extract that .zip folder and use it from command prompt.

uiae@uiae:~ path/to/atom.exe --version

Atom : 1.13.1
Electron: 1.3.13
Chrome : 52.0.2743.82
Node : 6.5.0

PS: This discussion platform lacks edit buttons.