"Open With Atom" disappeared for opening folders (on Linux Mint in Caja)


#1

I’ve been trying to figure this out and fix it for the longest time now… When trying to open a folder in Atom, I can’t seem too do it, no matter what I change…

Keep in mind, this is on Linux Mint, using the Caja file system…

To help explain more, when you right click a file, at the top you see “Open With Atom”, as you see in this picture below:

… But when I try to do it on the folder:

And as you can see, there is no “Open With Atom” at the top of this, which is what I would like…

Sure, I could go into the “Open With” > “Other Application” > “Atom”… But this takes too long… And even when I tick the “use this application as default”, Atom still wont appear at the top of the right click menu, nor in the “Open With” menu… So every time I want to open a folder, I have to do
"Open With" > “Other Application” > “Atom”…

I’ve changed the file located at /usr/share/applications/atom.desktop to include this:

MimeType=text/plain;inode/desktop

But still, it wont show up…

How would I fix a problem like this?


No "Open With Atom" context menu entry with Nautilus
#2

I’m confused. You say the item “disappeared”? I’m not sure it ever existed for folders?


#3

It used to exist for me… Perhaps you are using a different file browser than Caja that didn’t support it.


#4

Sounds like a bug then. You may want to file a bug on https://github.com/atom/atom/issues. If you do, please post a link to the bug in this topic :grinning:


#5

On Ubuntu I don’t have Open With Atom context items for files or folders. I’m not sure that is already meant to be supported for Linux?


#6

That depends on file manager you’re using. Depends if it handles that or not. That being said, as far as I’m aware, Ubuntu uses a different file manager from Linux Mint, Linux Mint by default uses Caja.


#7

Yea it’s Nautilus, I believe.
I’m not sure, but I vaguely remember that it may need a separate package to enable context menu entries like that, so you could be right.


#8

Actually, my bad… At the time of writing that I guess I was really tired or something. Your file manager depends on your DE, not your OS. So, I’m using Linux Mint /w MATE, and by default, MATE uses Caja. Whereas Ubuntu uses the Unity DE, and Unity probably uses a different file manager.