Open on GitHub commands doing nothing

I’ve cloned a github repo in Atom successfully. However, nothing happens whenever I run one of the Open On GitHub commands. Is there some sort of prerequisite/dependency that I need to take care of for the Open On GitHub commands to function?

Atom : 1.39.0
Electron: 3.1.10
Chrome : 66.0.3359.181
Node : 10.2.0

I haven’t encountered an “Open on GitHub” command, so it might be helpful if you gave more information about the context in which you’re encountering this command. If I can identify the package, I can look at the code and tell you precisely what it wants.

1 Like

Here is where the package comes from:

And the context is that I’m running “Open on GitHub:file” (or any of the other Open on GitHub:) from the command palette.

Okay, thanks. I just tried it, and it works for me, so let’s see what’s different for you. Mind sharing the link to the GitHub repo you cloned? Does Atom fully recognize your repository and highlight your added/changed files correctly?

Atom is recognizing the repo properly. I was able to do commits and push up to the remote GitHub repo (https://github.com/kpause/starter-web).

Suspect something wrong with my system. Is there a developer mode I can turn on or something that would allow me to see exceptions/errors?

Since it’s built on a chassis of Google Chrome, Atom has full-featured developer tools that you can access from the menu bar or a hotkey.

Ugh - figured it out. User error. I wasn’t in the context of the edited file when running the command. I was in the project tree. Sorry for the bother!!!

1 Like