"Open empty editor on start" does nothing


#1

This means it’s supposed to open a new document on load, right? Well, whether it’s selected or not, it loads my last project, even if the folder it’s opening has been removed.


How do I get Atom to open an empty window on startup?
Atom keeps on opening non-existing file on startup
#2

Where do you see this option?


#3

It’s under Core Settings, the last checkbox on the page. Second option from the bottom.


#4

I see … I’m running the latest Beta version at work and that feature hasn’t made it into the Beta releases yet. It appears there is a bug in the feature. You may want to file an Issue and reference the PR that added it:


#5

Sure… What’s PR short for in this context?


#6

PR is short for Pull Request, a proposed modification to the code in the repository.


#7

Got it. Thanks.

Link is here. https://github.com/atom/atom/issues/9338


#8

This option never works for me. Anything I can do to get it to work?


#9

The Open Empty Editor On Start setting is only for opening an untitled tab when opening an empty Atom window. If you want to disable restoring the previous session completely you need to use the core.restorePreviousWindowsOnStart setting which currently is only available by editing your config.cson file.


#10

Even with restorePreviousWindowsOnStart: false under core in my config.cson file, Atom still starts up with the last thing I had open.