One project does not scroll anymore


#1

I’ve opened one project where I get very strange scrolling behavior: For long YAML and Markdown files, there is no scroll bar, turning the mouse wheel does nothing, moving the cursor only changes the position in the footer but puts the cursor itself out of sight, etc. I only get this behavior in this specific project, other long files in the project do scroll and YAML and Markdown files in other projects scroll too. I tried restarting Atom, I’ve tried closing the project and reopening it, but the scroll behavior persists. I’ve tried deleting ~/.atom/storage, but that also did not help.

Did I accidentally activate some setting or mode that does this? Or is this a bug?

Platform is Mac OS X 10.11, Atom version 1.27.2


#2

Does this happen in safe mode? Try opening Atom with atom --safe


#3

Yes, this also happens in safe mode.


#4

What happens if you start with atom --clear-window-state? This will wipe out all unsaved files, so make sure that you have everything battened down before you use it.


#5

That solved the issue. Thank you so much!


#6

This is an uncommon occurrence, but a variety of bugs can occur with how Atom serializes data about the position of everything in the window. Due to the transient and unpredictable nature of the issue, it’s hard to pinpoint the problem, and sometimes the bug occurs with no harm done. Sometimes, apparently, the harm comes in the form of a missing scrollbar. In this case, dropping the old window data is the best solution.