One click install package


#1

hi, is it too difficult for atom team to install package on one click?

i mean if there is need for crap like visual studio and python etc then do it. please install all required apps and dont ask me any question.

that would be nice a feature and great help


Not able to install packages on atom 1.29 verson
#2

I’m not sure what you mean. All you need to do is search for the package you want inside Atom and press Install. That’s one click.


#3

unfortunately that is not one click done thing. i am getting same error on any package i select to install and that error is about visual studio and python. let me paste it here if i can copy the text.

The Errors:
Installing “autocomplete-html-entities@0.2.0” failed.Show output…

Compiler tools not found

Packages that depend on modules that contain C/C++ code will fail to install.

Read here for instructions on installing Python and Visual Studio.

Run apm install --check after installing to test compiling a native module.

moreover that:
i got both of the required apps installed already but atom cant see those.

hey thanks for this very quick reply


#4

This is not normal. Only packages that require building native modules like atom-terminal-tab should require compiler tools. What version of Atom and Windows are you using? With an error like this, you should try uninstalling and reinstalling Atom from a fresh download just in case something went wrong with the first install.


#5

hmm, i dont think i did something wrong. i double clicked the setup exe and Atom was ready. i removed visual studio code after that because Atom is simple and faster compared to VScode.

atomversion

Well, a new user can post just one picture. no problem

OS: Windows 8.1 64bit

Thanks


#6

btw, i have reinstalled Atom and checked package install but getting same errors.


#7

I don’t know why it’s happening.

What happens if you open the command line and enter apm install script?


#8

‘apm’ is not recognized as an internal or external command,operable program or batch file.

i remember when Atom was installed first time, i tried to use ‘apm’ command but i got same error. i removed Atom and reinstalled. later i found the way to install package through Settings. i did not bother about apm after that.

is it firewall blocking some unknown module execute behind the scene? i gave Access (outbound) to just atom exe.

The shortcut: C:\Users\me\AppData\Local\atom\app-1.29.0\atom.exe --squirrel-firstrun


#9

Let’s try adding AppData/Local/atom/bin to your system PATH and see if that changes anything.

is it firewall blocking some unknown module execute behind the scene?

I can’t see why it would.


#10

C:\Windows\system32>apm install script
Installing script to C:\Users\me.atom\packages failed
Request for package information failed: connect EACCES 34.238.48.57:443 (EACCES)


#11

oh sorry, let me add firewall rule for apm


#12

What do you see when you enter apm install --check?


#13

C:\Windows\system32>apm install script
Installing script to C:\Users\me.atom\packages failed
Request for package information failed: getaddrinfo ENOTFOUND atom.io atom.io:44
3 (ENOTFOUND)

added firewall access for apm. And there are ‘node’ and ‘npm’ in the same folder. no idea either my global node should work or the one that comes with Atom. I gave firewall access to both node and npm too (atom provided). But

Settings -> Package shows following error

damhttp

(sorry, a friend called me ,thats why i could not respond back with with command result)


#14

C:\Windows\system32>apm install --check
Checking for native build tools done


#15

Ok, following steps worked for me.

Add firewall rules for node and npm that Atom provides because my global node and npm is not used by package installer. both can be found in the folder where apm is located. my system have it on this path C:\Users\me\AppData\Local\atom\app-1.29.0\resources\app\apm\bin\

Make sure you reopen Atom if it was already opened when you added firewall rules otherwise you will get error message if try to install package.

Dont forget to add atom.exe in outbound rules of your firewall.

Also add apm.exe path in your system path.

Also keep in mind that node and npm that Atom installed is used because when i added apm path in the system path that actually set system path for node and npm too. This may create issues for other apps that rely on your previous node installation.

i will remove apm from system path after i get the package installed just to avoid any other issues with my other apps.

Better enable firewall rules for Atom only when you need to install new package


#16


#17

The only Atom folder in your PATH should be AppData/Local/atom/bin/. If you change that, you shouldn’t have any weird interactions with the Node/NPM that come packaged with Atom. If you don’t change it, the PATH reference will break when Atom updates and app-1.29.0/ is deleted and replaced by app-1.30.0/.


#18

Path does not exist on my system. i mean that the bin folder does not exist.

did i miss some important point?

noBin


#19

Only that you didn’t tell me that earlier. I don’t know why it happened, but I’ve seen a couple of other people with the same problem. I recommend reinstalling Atom afresh to see if that fixes it. If it doesn’t, you can create a bin folder with these files in it. All they are is two batch scripts and two shell scripts that point to the apm and atom executables inside your current app-x.x.x folder, and when everything is working correctly they get modified every update.