On startup atom keeps saying "wait for to respond"


#1

This has been hapening for awhile now. I can’t explain it.

On startup, if a random project is open, that project will consistently hang on startup and keep showing the “wait for respond” message like in screenshot below.

My solution has been to create a new non-project window, then add that project into this window with Ctrl + Alt + O, that way it forgets all the files it had open. And then it works.

Any solution to this?


#2

I believe that this is happening due to certain plugins that are not compatible with your version.

I would suggest downloading a previous version from https://github.com/atom/atom/releases.

I had the same problem, but downloading 1.12.3 and overwriting the last version temporarily solved the problem for me.

I hope that a future release or plugin updates will fix this at one point.


#3

Don’t follow @roberteles’ suggestion just yet. You can find out for sure if it’s a package causing the issue by starting Atom from the command line with atom --safe to put it into safe mode, which doesn’t load any third-party packages.


#4

I agree with @DamnedScholar.

In my case, atom --safe was the first thing I tested and it worked, thus I figured that one of the plugins may be faulty.


#5

Thank you folks! The next time it happens I will try this and update you.