Npm run release error


#1

Trying to build an exe for my code was working fine and then had to add npm package @paulcbetts/system-idle-time and change some things with post install scripts to get it to work. Any idea why I cant build a release?

$ npm run release

@ release C:\Users\jpmim\Software\Project1

gulp release --env=production

[01:46:17] Using gulpfile ~\Software\Project1
\gulpfile.js
[01:46:17] Starting ‘clean’…
[01:46:24] Finished ‘clean’ after 6.95 s
[01:46:24] Starting ‘transpile’…
[01:46:24] Starting ‘less’…
[01:46:24] Starting ‘copy’…
[01:46:24] Starting ‘finalize’…
[01:46:24] Finished ‘finalize’ after 33 ms
[01:46:24] Finished ‘less’ after 48 ms
[01:46:27] Finished ‘transpile’ after 3.36 s
[01:48:56] Finished ‘copy’ after 2.53 min
[01:48:56] Starting ‘build’…
[01:48:56] Finished ‘build’ after 7.9 μs
[01:48:56] Starting ‘release’…
[01:50:03] Building installer with NSIS…
Processing config: C:\Program Files (x86)\NSIS\nsisconf.nsh
Processing script file: “C:\Users\jpmim\Software\Project1\tmp\installer.nsi” (ACP)
File: failed opening file "C:\Users\jpmim\Software\Project1\tmp\Project1\resources\app\node_modules\electron-rebuild\node_modules\electron-prebuilt\node_modules\electron-download\node_modules\nugget\node_modules\pretty-bytes\node_modules\meow\node_modules\normalize-package-data.npmignore"
Error in script “C:\Users\jpmim\Software\Project1\tmp\installer.nsi” on line 98 – aborting creation process
[01:52:37] Installer ready! C:\Users\jpmim\Software\Project1\releases\Project1.exe
[01:52:39] Finished ‘release’ after 3.72 min


#2

I have found this error occurs because of this https://github.com/electron/grunt-electron-installer/issues/39

Any help would still be appreciated


#3

What version of NPM are you using?


#4

v4.6.0 node
2.15.9 npm


#5

Upgrade to NPM 3, delete node_modules, and re-run npm install.


#6

Thanks tried that and it did not work. Any other ideas?


#7

How didn’t it work? Do you still get the same error? Did you delete node_mdoules and re-run npm install?