Notification popup on every keystroke


#1

New to Atom. Windows 7. Editor worked very well until I browsed packages (from menu prompt) Not sure what I may have toggled, but now Atom throws a notification window on every keystroke, and will not even accept some keys, like the backspace key. I’ve searched the bug listings, and googled from a few different directions, but I come up with nothing. This is rendering the editor unusable, I’d like to buy a clue!


#2

A picture would be nice.
Popup named Key binding resolver?
Toggle … Ctrl + . (control and dot keys) or Esc

See also: How do I close the key Binding Resolver panel?


#3


#4

I’ve got a theory. From Atom’s title bar, I can see that your user folder is on D:, but the error message is looking for a module in C:. Atom should have installed itself to %USERPROFILE%/AppData/Local/atom. My hypothesis is that it did, but then something else has C: hard-coded into its path, and that’s messing with things?

I don’t know if it’s possible to get in and change that path, but something that should fix it would be to install Atom in portable mode. If you close Atom completely, uninstall the old version, and set up a portable install, you can then copy your .atom folder into the directory you’ve installed Atom to.


#5

In addition to what @DamnedScholar said, do you have any antiviruses running? If so, which ones?


#6

Very good theory. I’ll check it out.


#7

Yes, I am running Vipre.


#8

It would be a worthwhile experiment to disable the antivirus program and then attempt to reinstall Atom. Atom doesn’t install like most programs, so some of the changes that the installer makes can raise red flags just because they’re irregular. It’s possible that the AV could have blocked a write operation that would have plugged the correct path in. I don’t know how that would have worked, but there’s such a broad umbrella of potential interactions with different AV programs that it’s always a good debug step when the installation seems to have gone wrong.


#9

Yes, typically this error occurs due to an antivirus preventing Atom from successfully copying over all of its required components. So Atom will start but then continuously spew errors due to those missing files. So temporarily disabling Vipre then reinstalling Atom should be a good first start.