Not scrolling when selecting?


#1

Continuing the discussion from Category suggestion: Lounge:

Have you opened a bug on this? This is definitely not the case on OS X. Or am I misunderstanding?


#2

I just tested and it worked. As recently as yesterday it didn’t and it was the same Atom version. I just thought it never worked. I will pay more attention when it happens.


#3

I found the problem. If you double select a word and then scroll it doesn’t auto-scroll. I do this all the time.


#4

Looks like there’s a somewhat similar bug open:


#5

Close, but that’s a performance problem not a functional one.


#6

Perhaps … they might not have tried scrolling. It wouldn’t hurt to weigh in with repro steps.


#7

It’s worse than this. Twice today it got in a state where it wouldn’t scroll. It was a normal single cursor and when dragging it the pane wouldn’t scroll. I just now got out the gif capture util to show you but when I re-sized the pane the problem went away. Next time I will leave the pane at the big size and take a big capture.

I’m suspecting that it is a certain combination of pane size and initial cursor position. Maybe a 1-pixel dead zone or something, whatever that means.


#8

@leedohm: I’ve found the second cause of scrolling not working. It never works when clicking and dragging in the gutter. I should have noticed this. The other cause was when starting with a double-click. Should I report these?


#9

Do you mean the gutter with the line numbers and the diff symbols? I would never have thought to scroll a window by clicking and dragging in there … do other editors let you do that?