Not opening properly, even after reinstall


#1

I’ve been using Atom for HTML/CSS for almost year now with no issues. I have no idea what happened, but yesterday when I tried to use it, instead of opening the program like normal, I got this:

Rebooting my machine and reinstalling Atom didn’t seem to do anything. I code as a hobby and am not particularly computer savvy, so that’s pretty much the extent of my own troubleshooting abilities. Any advice to help getting it working again would be appreciated.


#2

If you click on Console, what’s the error message that you see? What happens if you start Atom from the command line with atom --safe?


#3

Here are the error messages. Starting from the command line didn’t seem to do anything, just started the program on the console tab instead of the elements tab.


#4

According to that error message, the folder .atom/compile-cache/ has some permission issues, which may have been due to Atom running with administrator permissions when it created the folder. Whatever the case, you can safely delete the whole compile-cache/. It just exists to make Atom start up more quickly, and will be regenerated if it goes away.


#5

That seems to have fixed it, thank you.


#6

No problem. :slight_smile: